We're Here To Help

Name is required.
Email address is required.
Invalid email address
Answer is required.
Exceeding max length of 5KB

Not working

Tom Semmes Apr 07, 2016 06:40AM EDT

I have installed 8 ft. White Linear Track Lighting that I purchased from Home Depot. Everything seems installed properly. The outlet works. The bulbs are working. But I can not get the system to work. Would it have to do with how I installed the Nuvo Lighting Gimbals? The instructions that came with them have very little description. Just images and a single word "Sink" which accordingly the dictionary means "go down below the surface of something, especially of a liquid; become submerged." or "descend, drop". which only leaves me more confused. But it looks easy to install: just insert the base of the gimbal and twist until it clicks in. Which I did, plugged in the cord and turned it on. But nothing happens. Any possibility I did something wrong?

Up 0 rated Down
Michael Kenwood Apr 07, 2016 02:25PM EDT Satco Products, Inc Agent

Hi Tom,
Would you be able to give us the model numbers you purchased. We are not sure of the products you are describing. If you don’t have the model numbers, a digital picture will be very helpful.

Thanks
Mike

Up 0 rated Down
Michael Kenwood Apr 25, 2016 10:18AM EDT Satco Products, Inc Agent

Hi Tom,

Would you be able to give me the model numbers of the system you bought, or if you don’t have the model numbers digital images would be great.

Thanks,
Mike Kenwood

This question has received the maximum number of answers.

Need More Help?

professionals@satco.com
https://cdn.desk.com/
false
desk
Loading
seconds ago
a minute ago
minutes ago
an hour ago
hours ago
a day ago
days ago
about
false
Invalid characters found
/customer/en/portal/articles/autocomplete